OpenLP 2 Introduction and FAQ

From OpenLP
(Redirected from Bug)
Jump to: navigation, search

Contents

General Questions

What is OpenLP?

OpenLP is presentation software developed for churches to provide a single easy to use interface for the projection needs of a typical worship service. First created in 2004, it has steadily grown in features and maturity such that it is now a mainstay in hundreds of churches around the world.

The name "OpenLP" is a contraction of "Open Source Lyrics Projection". It is not an abbreviation. The L and the P do not stand for anything, and the name is a single word with an uppercase O, an uppercase L and an uppercase P. It is not "Openlp", "Open LP" or "OpenLp", or even "Open Lp". That said, it is pronounced, "open el pea".

OpenLP has searchable databases of songs and Bible verses allowing them to be projected instantly or saved in a pre-prepared order of service file. Themes allow for a variety of presentation options and allow you to add attractive visuals to enhance your presentations. PowerPoint and LibreOffice/OpenOffice presentations, videos and audio files can be run from within the program removing the need to switch between different programs. Alert messages can be displayed so the nursery or car park stewards can notify the congregation easily. Remote capability allows the worship leader to change songs, or for alert messages to be sent from anywhere on the network, even via a smart phone or tablet.

Being free, this software can be installed on as many PCs as required, including the home PCs of worship leader(s) at no additional cost. Compared to the expensive site licenses and restrictions of commercial software we believe OpenLP is the perfect choice for quality and value. Still in active development by a growing team of enthusiastic developers, features are being added all the time resulting in continual improvement of the software.

OpenLP is licensed under the GNU General Public License, which means that it is free to use, distribute, modify, and it stays free.

Can I help with OpenLP?

OpenLP is possible because of the commitment of individuals. If you would like to help there are several things that you can get involved with. Please see: Contributing for more information.

I use and like OpenLP and would like to tell others online. Where can I do this?

A variety of places!

  • Are you on facebook? Then become a fan
  • Are you on twitter? Then follow openlp, and retweet the annoucements.
  • Give us a +1 on Google+
  • Give us a thumbs up on the SourceForge project page
  • If you have a website or blog, then link to our site http://www.openlp.org with a few words saying what the software is and why you like it.
  • Add a placemark on our Worldwide Usage map, so others in your locality can see someone close by is using it
  • If you are a member of any Christian Forums or websites, and their rules allow it, then perhaps review the software or ask others to review it.

What operating systems does OpenLP support?

OpenLP is designed to be cross platform. Currently it has been known to run on Windows (XP, Vista, 7, 8, 10), Linux (Ubuntu/Kubuntu/Xubuntu, Fedora, Arch Linux, OpenSUSE, Debian), FreeBSD & Mac OSX. Please let us know if you've successfully run it on something else.

Which programming language is 2.x developed in?

OpenLP 2.x is written in Python and uses the Qt5 toolkit. Both are cross-platform which allows the software to run on different types of computers and so allow more people access to free worship software. Python is one of the easier programming languages to learn, so this helps us develop and find bugs quicker, and also allows more developers to contribute with the project.

Which written languages does OpenLP support?

We have support for a number languages which can be seen on the Settings->Translate menu. However some of these translations are incomplete. If you would like to help complete or start to translate OpenLP into your language then see the Getting started page.

Upgrading

Are there any special steps to take before upgrading to 2.1.x?

If you want to use the data from the previous version of OpenLP you will need to upgrade to OpenLP 2.0.5 before upgrading to OpenLP 2.1.x

Does 2.1.x replace 2.0.x, or can they be run side by side?

To install OpenLP 2.1.x previous versions of OpenLP 1.9.x and 2.0.x will be removed. Your databases and settings will remain intact.

When starting OpenLP 2.1.x for the first time it will offer to back up your data from your 2.0.5 installation before converting to data to be compatible with the new version. Once you have converted the data, you will not be able to use this data in an earlier version. For that reason we strongly recommend that you allow OpenLP 2.1.x to perform the backup.

Are 2.1.x and 2.0.x compatible?

No. Upon upgrading from OpenLP 2.0.5 to 2.1.x your data will automatically be converted to work with the latest version. This conversion is not reversible, however OpenLP 2.1.x will offer to backup your data prior to conversion.

Using OpenLP

Why are there black bars down the sides of my themes?

In short, you are looking at a generated preview thumbnail, not a true representation of your theme, and those "black bars" is actually just the background behind the image.

Thumbnails, not themes

When OpenLP creates the theme, it creates a thumbnail preview of the theme too, and this is what you are actually looking at. Themes themselves are dynamic, and will adapt as best as they can to the size of the projector. However, OpenLP does not stretch images, and so if your projector's output is wider than your theme's background image, you will still see the black background on either side.

Using the projector for accuracy

It is strongly recommended that you set up OpenLP with your projector attached. This way you can make sure you have the most accurate set up, one which should be the same when you actually use OpenLP in your church service.

Is there a manual or any documentation for 2.0?

Some folks are working on a brand new manual for OpenLP 2.0. You can find the latest version of this manual at http://manual.openlp.org/. If you need help, use the live chat feature or ask in the forums. If you would like to help write the manual, please let us know - we are always happy for new volunteers to join the team and contribute to the project.

I've started OpenLP, but I can't see the songs or bibles section in the Media Manager

When you installed OpenLP, the first time wizard would have asked which plugins you wanted, and songs and bibles should have been selected. If for some reason they were not, then you will need to activate them yourself. See How do I activate / deactivate a plugin for instructions.

How do I activate / deactivate a plugin?

Plugins can be turned on and off from the Plugin List Screen. Select the plugin you wish to start/stop and change its status. You should not need to restart OpenLP.

What are these plugins that I keep seeing mentioned?

The plugins allow OpenLP to be extended easily. A number have been written (Songs, Bibles, Presentations) etc. but it is possible for the application to be extended with the functionality only you require. If this is the case then go for it but let us know as we can help and it may be something someone else wants.

How do I enable Powerpoint/Impress/Powerpoint Viewer?

First of all ensure that the presentation plugin is enabled (see above). Then to enable a presentation application, go to the Settings dialog, switch to the Presentations tab and check one of the enabled checkboxes. OpenLP will automatically detect which of the three you have installed, and enable the appropriate checkbox(es). Check the applications you require, and then restart OpenLP for the change to be detected. Note, PowerPoint Viewer 2010 is not yet supported, use 2003 or 2007.

See also I'm on Windows and PowerPoint is installed, but it doesn't appear as an option and Why is there no presentations plugin available on OS X?

Why is there no presentations plugin available on OS X?

Currently the presentations plugin is not bundled with OpenLP on OS X. The reason for that is that the LibreOffice/OpenOffice.org version on Mac OS X does not contain the (more exact: does only contain a broken) interoperability component (the so called pyuno bridge) which could be used by OpenLP. As soon as the interoperability component works on OS X we can re-enable the plugin and bundle it. We are really sorry for that.

Is it possible to get Bible x? How?

The Bible plugin has a much improved Import Wizard which can import Bibles from a variety of sources. The following sources are supported:

  • Openlp.org 1.x import
  • CSV (in the same format as openlp.org 1.x)
  • OSIS (many translations are provided by the Zefania XML project. Translations from the Sword Project can be converted using the mod2osis tool)
    • After using the Sword software Media Manager to download the required bible.
    • From the command line (works on Windows and Linux):
      mod2osis <name> > name.osis
      Note the <name> is case sensitive on all environments and should be the name of your bible, e.g. ESV.
    • The Bible import wizard will the read name.osis file and import your bible.
  • OpenSong
  • Web Download

Why do my Bible verses take a long time to load when using a Web Bible?

In order to better conform to copyright law, the Web Download Bibles are not downloaded when you import them, but on the fly as you search for them. As a result, the search takes a little longer if you need to download those particular verses. Having said that, the Web Download Bibles cache downloaded verses so that you don't need to download them again.

My Bible is on the Web Download sites, but my Church isn't on the internet. What options do I have?

When you create and save a service, all the items in the service are saved with it. That means any images, presentations, songs and media items are saved. This is also true for bibles. What this means is you can create the service on your home computer, insert a bible passage from the web, save it and then open the service using your church computer and voila, the bible passage should be there! Note this can also be done with songs, etc!

I've imported the wrong Bible, how do I delete it?

There is a delete button on the toolbar on the Bible's Media Manager panel. Note this may move into the meta data editor in later versions to reduce the risk of accidental deletion.

Can I use VLC?

Since version 1.9.9, OpenLP can use VLC to play videos.

Playing DVDs

OpenLP can use VLC to play DVDs from version 2.1.1 onwards.

Background video

At the moment, OpenLP cannot use VLC to play background videos.

Live video capture

At the moment, OpenLP cannot use VLC for live video capture.

(Advanced) Where do I find the configuration file?

Linux, FreeBSD & PC-BSD

If your distribution supports the XDG standard, you'll find OpenLP's configuration file in:

/home/<user>/.config/OpenLP/OpenLP.conf

If that file and/or directory does not exist, look for:

/home/<user>/.openlp/openlp.conf

In most file managers you can simply click or double-click on the file and it will be opened for editing. If not, just use a text editor like Kate or gEdit.

OS X

You'll find your configuration file here:

/Users/<user>/Library/Preferences/org.openlp.OpenLP.plist

Double-click on this file to edit it in the Property List Editor.

Windows

On Windows, OpenLP does not use a configuration file, it uses the Windows registry. You can find the settings here:

HKEY_CURRENT_USER\Software\OpenLP\OpenLP

To edit the settings, click on Start, Run, type in "regedit.exe" and press Enter. Navigate down the tree to the OpenLP folder.

(Advanced) Using MySQL or PostgreSQL to store songs

Please Note:  MySQL and PostgreSQL are not meant to be used over the Internet. Not only is this insecure, but your connection will be excruciatingly slow, and will cause OpenLP to hang.

It is possible to use MySQL or PostgreSQL to store the songs so that you can share them across a network. Currently you can only do this by manually editing the OpenLP settings.

You need to change the database type from sqlite to mysql+mysqlconnector or postgresql. There are 4 additional values you need to add to the settings as well.

Once you have done this (as per the setup steps for your operating system below), run OpenLP. This will create the tables automatically. You can import your existing songs, via the File -> Import -> Songs -> OpenLP v2 option. The location of the songs.sqlite database is documented elsewhere in this FAQ.

Windows

On Windows, create a text file containing the following snippet, putting your own settings where applicable. Rename the file so it ends in .reg, and then double click the file to load it into the registry.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\OpenLP\OpenLP\songs]
"db username"="user"
"db password"="password"
"db hostname"="host"
"db database"="test"
"db type"="mysql+mysqlconnector"


Linux/FreeBSD/PC-BSD

In the OpenLP configuration file, find the [songs] section, and edit the db type value, setting it to your desired database type (as per above). Then add the 4 extra values. At the end of all of this, your values should look like this:

db type = mysql+mysqlconnector
db username = username
db password = password
db hostname = server
db database = database_name

Mac OS X

In the OpenLP property file, find the songs.db type property, and change it to your desired database type. Then add 4 more properties, and set them each to their correct values. At the end of the day you should have a set of properties that looks something like this:

songs.db type = mysql+mysqlconnector
songs.db username = username
songs.db password = password
songs.db hostname = server
songs.db database = database_name

You can also set these settings via the following terminal commands

defaults write org.openlp.OpenLP "songs.db type" "mysql+mysqlconnector"
defaults write org.openlp.OpenLP "songs.db username" "root"
defaults write org.openlp.OpenLP "songs.db password" "****"
defaults write org.openlp.OpenLP "songs.db hostname" "127.0.0.1"
defaults write org.openlp.OpenLP "songs.db database" "openlp"

If you need to restore settings to defaults, the following will safely remove the above changes

defaults delete org.openlp.OpenLP "songs.db type"
defaults delete org.openlp.OpenLP "songs.db username"
defaults delete org.openlp.OpenLP "songs.db password"
defaults delete org.openlp.OpenLP "songs.db hostname"
defaults delete org.openlp.OpenLP "songs.db database"

Disabling the Impress Presenter Console

From version 3.5, it appears that LibreOffice now comes with a Presenter View. This is very useful if using Impress on its own. However when using with OpenLP it can be in the way. It doesn't appear possible to disable this within LibreOffice/Impress itself, and as it is installed as part of LibreOffice it cannot be disabled in the Extension Manager.

To disable this in Windows, it will be necessary to go into the Windows Add/Remove Program and choose to "Change" LibreOffice. Select the "Modify" option in the installer that appears. In the Custom setup, expand "Optional Components" , "Extensions" and select "Presenter Screen". In the dropdown box on the left, choose the "This feature will not be available" option. Then step through the installer wizard, and the option will be disabled.

On other operating systems it may be possible to remove this via your package manager. If all else fails, check the installation folder for LibreOffice, and in the "share\extensions" folder, try removing the presenter-console folder.

Troubleshooting

Windows Error Reporting

Folks on Windows need to disable Windows error reporting. Follow the article on HowToGeek to disable error reporting on Windows XP, Vista and 7.

Something has gone wrong, what should I do to help get it fixed?

OpenLP Doesn't Start Up Properly

If OpenLP shows the splash screen but doesn't get any further, or OpenLP doesn't show up at all, you need to do the following before continuing further:

  1. Run OpenLP in debug mode (i.e. with debug logging)
  2. Find and open the log file
  3. Open http://pastebin.com/ in your browser and copy and paste the contents of the log file into the web page
  4. Click the submit button at the bottom of the page
  5. Copy the URL (address) of the new page and have it handy when you enter the IRC channel

I See a Bug Window (with an Oops Message)

It looks like you have found an error in the program (what we call a bug). You should report this to us so that OpenLP can be improved. Before reporting any bugs please first make sure that there isn't already a bug report about your problem:

  1. Check the troubleshooting forum
  2. Check the Launchpad bug list

If there is already a bug report, you may be able to help by providing further information. However, if no one else has reported it yet, then please post a new bug report.

  1. Send unreported bugs via e-mail to bugs (at) openlp.org - this way we can determine the cause of the bug, and assign it the appropriate priority
  2. You can also file the bug on our bugs list on Launchpad, though we prefer you to use the above method.
  3. We are moving away from reporting bugs on the forums, so please rather use one of the above options.

What information should I include in a bug report?

  • Operating System
    • Version
    • Distribution - Ubuntu, Fedora, etc (if you're using Linux)
    • Edition - Home, Basic, Business, etc (if you're using Windows)
  • Version of OpenLP (Help -> About)
  • The exact steps to take in order to reproduce the error
  • Version of MS Office or OpenOffice (if you're using the song imports or the presentation plugin)
  • What Bible translation and type you are importing (if you're using the Bible importer)
  • Any other information that might remotely be related or useful.

The more information you give us, the better we can help you.

I've been asked to email a debug log, where do I find this?

We may need a debug log to help pin-point the issue. A new log file is created each time you start OpenLP so copy the file before you run the software a second time. On Windows a Debug option is available in the start menu. On other systems, you will need to run OpenLP from the command line, with the following option: -l debug. Please note, that is a lowercase L.

If you aren't sending it to the support team, then please do not paste the log contents straight into a forum post. Instead, open the log file in a text editor (such as notepad on Windows or gedit on Ubuntu) and copy and paste the contents into somewhere like [1]. Then give us the link to the page that is created.

Windows
  1. Find the OpenLP folder in your Start menu. Choose the "OpenLP (Debug)" option.
  2. OpenLP will start up. Go to the Tools -> Open Data Folder menu option
  3. Windows Explorer will appear containing folders such as "alerts," "bibles," "custom," etc. Keep this Explorer window open.
  4. Now repeat the steps you need to take in OpenLP to reproduce the problem you had
  5. Close down OpenLP.
  6. In Windows Explorer, which you left open, navigate up one level into the "openlp" folder. You will see the openlp.log file. This is the file to e-mail.
If OpenLP Doesn't Start Properly on Windows

Note, if OpenLP doesn't start and you can't get to the Tools menu, you can find the log file by following the directions below:

  1. Pressing the Windows Key and "R" at the same time
  2. Type the following into the Run dialog, and press <Enter>:
%appdata%\OpenLP


Linux

If you installed OpenLP from a package:

@:~$ openlp -l debug

Alternately, if you're running OpenLP from source:

@:~$ ./openlp.pyw -l debug

If your Linux distribution supports the XDG standard, you'll find the log in:

~/.cache/openlp/openlp.log

Otherwise, you'll find the log file in:

~/.openlp/openlp.log
Mac OS X

Open Terminal.app and navigate to where you installed OpenLP, usually /Applications:

@:~$ cd /Applications

Then go into the OpenLP.app directory, down to the OpenLP executable:

@:~$ cd OpenLP.app/Contents/MacOS

And then run OpenLP in debug mode:

@:~$ ./OpenLP -l debug

Once you've done that, you need to get the log file. In your home directory, open the Library directory, and the Application Support directory within that. Then open the openlp directory, and you should find the openlp.log file in that directory:

/Users/<username>/Library/Application Support/openlp/openlp.log

I'm on Windows and PowerPoint is installed, but it doesn't appear as an option

Try installing the Visual C++ Runtime Redistributable.

PowerPoint is enabled and loads, but won't open or create thumbnails when adding PPTs

This has been known to happen when the PowerPoint installation is broken or incomplete. Possible solutions:

  • Go to Add and Remove Programs in the Control Panel, find Microsoft Office and select "Change"
  • First choose to "Repair" and step through the wizard.
  • If this doesn't fix it, again "Change" but this time choose "Add or Remove Features"
  • Find "Microsoft PowerPoint" and ensure all options underneath are set to "Run from My Computer"
  • Do the same for all the options under "Office Shared Features" and "Office Tools".
  • Continue through the wizard.

The command line shows many error messages

When running OpenLP from the command line, you might get something like this:

Logging to: /home/<User>/.config/openlp/openlp.log
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  VideoDisplay ( no objectName ). 
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ). 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

These error messages indicate that you need to install an appropriate backend for Phonon.

Linux/FreeBSD

If you're using Gnome, you need to install the GStreamer backend for Phonon. On Ubuntu you would install the phonon-backend-gstreamer package:

@:~$ sudo aptitude install phonon-backend-gstreamer

If you're using KDE, you need to install the Xine backend for Phonon. On Kubuntu you would install the phonon-backend-xine package:

@:~$ sudo aptitude install phonon-backend-xine

If you know which audiovisual system you're using, then install the appropriate backend.

phonon-backend-vlc may also be worth trying on some systems.

Windows & Mac OS X

Phonon should already be set up properly. If you're still having issues, let the developers know. However we recommend using VLC for playing videos on Windows.

There are no menu icons in OpenLP

This may affect (only) linux users with xfce. To solve the problem, follow the description here.

JPG images don't work

This is a known issue on some Windows XP systems. One solution is to convert the image into another format such as PNG. Alternatively installing the Visual C++ Runtime Redistributable might fix it.

MP3's and other audio formats don't work

This is a known issue on some systems, including some XP machines. Installing VLC and enabling this player in Settings -> Configure OpenLP -> Media should allow to play these.

Note however that VLC is not yet used for background audio on songs, there is no workaround for this yet. However installing OpenOffice has been known to fix the problem for one user. We don't know why!

Videos can be slow or pixelated. Background Videos are very slow

If playing video by themselves, try installing VLC, and selecting this player in Settings -> Configure OpenLP -> Media. If VLC isn't an option, then selecting Phonon might help instead.

As for text over video, we have no solution for speeding these up. Reducing the monitor resolution and avoiding shadows and outline text will help. We are hoping a future release of the toolkit we are using (QtWebKit) will help improve this, but there is no timeframe at present.

Features

What new features will I find in v2.1.x?

Take a look at the Complete list for a list of features added in this and previous releases.

I have a great idea for a new feature, where should I suggest it?

First of all check it isn't on the Feature Requests page. If it is, then you need to say no more, it's already been suggested! If it isn't on the list, then head to the development forum and post the idea there.